First time here? Check out the FAQ!
x

Problems with SSH+ and SSH servers on Psiphon3.

0 votes
asked by about Psiphon 3
edited by

I downloaded the latest version of Psiphon3 but all SSH+ and SSH servers are not working. What can I do?

1 Answer

0 votes
answered by (193k points)

In order to fix the issue, navigate to Start > Control Panel > System and Security > Windows Firewall > Allow a program through Windows Firewall and check the box next to Psiphon3. If you can't find the application in the "Allowed programs and features" window, press the Allow another program button, navigate to the installation directory, select the executable file and press Add.

After that, from the Advanced Settings select Inbound Rules > New Rule. Check the Port box, click Next, select All local Ports and follow the self-explained steps. Also, make sure that your security program doesn't block the connection. If the error persists, reinstall the application.

As you can see, the servers are working fine on my computer after I configured my antivirus and Windows Firewall to allow Psiphon3 to communicate:

SSH+:
enter image description here

SSH:
enter image description here

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...