First time here? Check out the FAQ!
x
 Windows  Mac  Android  Answers  Forum

Google Play Store says it needs background data even though I've already synced all the information.

+1 vote

When I go to Google Play Store, it says it needs background data. After I've synced everything, it still doesn't work. What should I do?

asked Jul 8, 2013 by anonymous
edited Jul 24, 2013 by Nadia B

52 Answers

+1 vote

If you are using on phone through mobile network may be it is due to them, otherwise check your wifi connection.

answered Jul 11, 2013 by anonymous
+1 vote

Do you think we are retarded?????

I have both on!! And background data is not restricted

answered Aug 15, 2013 by anonymous
0 votes

If you're having your background data on but it still says it's off, I had the same problem, try this, go to settings, apps, Google play store, and press force stop and clear data then try to open play store again. It worked for me.

answered Aug 18, 2013 by anonymous
Best answer and only solution that worked for my android phone!  I have spent about a week searching the forums and who knows how many variations of google inquiries I have put out there to get my Google Play to function. I was about (seriously folks) 15 minutes from doing a factory reset on my phone and starting all over.  Just wiping it all out, zip , I didn't care any more. Thank you so much anonymous!
ANONYMOUS....THANKS!!!! EVERYONE, THIS IS THE SOLUTION!!!JUST LIKE ANGLELSTAR, I WAS ABOUT TO GIVE UP..THIS WORKS
Thanks!!! Worked on my Nexus 5
Thank you so much anonymous....worked for me too.
I LOVE YOU IT WORKED!
YESSSSSS!!!! Finally found this answer. Relief - I was getting so ticked!!!!
Best answer - thanks a lot !
Anonymous you are The Best!!!
Perfect ... thank you. I've been having this problem intermittently for a while and your solution worked for me.
Thank you so much. I had tried everything else but no luck. Now it works.
0 votes

I did FORCE STOP and all but nothing helped me to run Google Play Store. Is there any more solution please?

answered Nov 12, 2013 by anonymous
0 votes

Thanks Anonymous, It worked fine for me.

answered Dec 20, 2013 by anonymous
0 votes

Hi had the same problem recently. I used forced stop before. But what also worked for me was simply clearing the memory in the RAM manager. This is probably a better "first step". Good luck!

answered Dec 27, 2013 by zahier (180 points)
0 votes

Go to Settings-> Data usage-> Google play store-> Uncheck Restrict background data

answered Jan 3, 2014 by anonymous
Yes, that's it! Worked on My Samsung Galaxy Note 8.
0 votes

Hi there, I also went to Settings> Application Manager> Force Stop the Google Play Service> Restarted the phone and Play Store worked fine afterwards.

answered Jan 6, 2014 by anonymous
This alone didn't work on my Note 8.0. I first had to do the following:
Settings> Date Usage> GooglePlay on the bottom uncheck "Restrict background data", then go to Settings> Applications> GooglePlay Service> Force Stop> Clear Data. Then reboot.  
Then GooglePlay was back as normal.
0 votes

The Force Stop did the trick for me as well. Greatly appreciate this information.

answered Jan 11, 2014 by anonymous
0 votes

Locked up Google Play Store App solution was to select Forced Stop fixed me too. Thanks

answered Jan 13, 2014 by anonymous

Your answer

Your name to display (optional):
Email me at this address if my answer is selected or commented on:
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...