First time here? Check out the FAQ!
x

BlueStacks is not opening.

0 votes
asked by about BlueStacks
edited by

I had been using BlueStacks for quite a number of days and it was working fine back then, but after a long gap I recently opened it again only to find that nothing happens on trying to open BlueStacks. The BlueStacks logo appears in task bar but it disappears after a while or when I hover above the logo, but the BlueStacks software never starts. Not even the loading screen! I've been looking for help since a long time but I haven't resolved the issue yet! I've tried installing through Bluestacks ThinInstaller to no use. The same issues continue. I have also updated my graphics card and disabled Windows Security Essentials and Windows Firewall. I've also tried to launch it in compatible mode, no effect! Please let me know if you have a possible solution!

1 Answer

0 votes
answered by (329k points)
edited by

It seems that no one suggested to simply created another username with same Administrator rights and perform another installation. Remove the current one from the PC, then use CCleaner to wipe the obsolete registry entries and download a new version of the software from its official website. Make sure to run it as Administrator and it should work. Visual Runtime C++ needs to also be updated to the latest version for maximum compatibility.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...