First time here? Check out the FAQ!
x

Is Syncman compatible with Mavericks OS 10.9.3?

0 votes
asked by about Syncman
edited by

Is Syncman compatible with Mavericks OS 10.9.3?

1 Answer

0 votes
answered by (25.4k points)

The requirements information that is released on its official webpage offers you only a single version of Mac: OS X 10.5 ‘Leopard’. But, I managed to install it on my Mac version: OS X 10.8.5 'Mountain Lion'. I recommend you to try to install this application on your Mac version and if you cannot do it, get in touch with the developer and ask him about its compatibility.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...