First time here? Check out the FAQ!
x

I can't load my Print Master 2012 application on MacBook Pro with Mac OS X 10.9.1 Mavericks.

0 votes
asked by
edited by

I can't load my PrintMaster 2012 application on MacBook Pro with Mac OS X 10.9.1. Mavericks. Are these two compatible?

1 Answer

0 votes
answered by (77.9k points)
edited by

It seems that the latest version of the PrintMaster Platinum, the version 6, is fully compatible with Mac OS X Mavericks. I recommend you to upgrade your software to the latest version in order to use it on your Mac. You can download the latest version from the official website.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...