First time here? Check out the FAQ!
x

I can't use PrintMaster 2012 Platinum with my MacBook Pro. It has OS X 10.9.1. Is this application compatible?

0 votes
asked by
edited by

I can't use PrintMaster 2012 Platinum with my MacBook Pro. It has OS X 10.9.1. Is this application compatible?

1 Answer

0 votes
answered by (132k points)

No, your application is not compatible with Mac OS X 10.9.1. The 2012 version can run only with Mac OS X 10.5 Leopard and Mac OS X 10.6 Snow Leopard. For your computer, you will need to purchase PrintMaster v6 Platinum 2014.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...