First time here? Check out the FAQ!
x

Running newer version on older computer.

0 votes
asked by about VeriAdmin
edited by

I was wondering if the version 7.5 of Veriadmin will work on older hardware?

1 Answer

0 votes
answered by (80k points)
edited by

Usually, newer programs can't be run on older systems because the technology is evolving fast, and new programs are build for the latest released hardware without taking in consideration the compatibility with older systems. To check if the latest version of Veriadmin will run on your computer, I suggest that you head over to a website like Scribd. It seems that the Installation Guide for the latest version can be downloaded from there. In the document mentioned, you will be able to find the system requirements that your computer needs to meet to install and run Veriadmin.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...