First time here? Check out the FAQ!
x

Can I use Memu on Window XP SP3?

0 votes
asked by (120 points) about MEmu
edited by

Can I use Memu on Window XP SP3?

1 Answer

0 votes
answered by (329k points)

No, you won't have the possibility to run Memu on the Windows XP SP3 operating systems because it's unsupported. Windows XP is an unsupported operating system that doesn't receive updates anymore. It's strongly advised to either update to Windows 7 or Windows 10.

Here are the system requirements for Memu:

Windows Vista/Windows 7 SP1/Windows 8.1/Windows 10
Intel or AMD x86 CPU (with Virtualization Technology support preferred)
GPU with OpenGL 2.0+ support
At least 1 GB free system memory
At least 2 GB of free disk space under installation path

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...