First time here? Check out the FAQ!
x

SubMagic 0.71 has stopped working on my computer.

0 votes
asked Jun 18 by Nils-Erik about SubMagic
edited Jun 19 by Robert Polubinski
Microsoft Visual C++ Runtime Library
Runtime Error!
Program: C:\Program Files (x86)\SubMagic\SubMagic.exe
This application has requested the Runtime to terminate it in an unusual way. Please contact the application support team for more information.

I receive this error message when I close the "Donate" window. I have uninstalled SubMagic and removed everything about SubMagic in the system registry, and reinstall it again but that does not help. My computer has Windows 10 Pro 64-bit system with automatic updates turned on, and Avira antivirus program. Is there anything I can do to make SubMagic working again?

Best Regards,
Nils-Erik Eklöf

4 Answers

0 votes
answered Jun 19 by Robert Polubinski (221,940 points)

You should try reinstalling the Visual Runtime C++ packages because if the software has been reinstalled and still shows the same error, then it's problem with the libraries or there is actually a bug in the code, which I highly doubt if the software worked normally again.

Troubleshooting Visual Runtime C++ can be a little hard and very ineffective, but you can at least try.

The only thing I recommend doing is to reinstall the packages you already have on your PC.

Go to the Control Panel > Programs > Uninstall a program and identify the major versions of Visual Runtime C++ installed, ignore the build number.

Then re-download the packages from the following website and SubMagic: https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

0 votes
answered Oct 1 by Dizzy Man

This seems to be a "known issue" with submagic (0.71). It connects to a server (to check if you want to donate?) and when it fails you get this runtime error. Best bet now is to go to version 0.70, which has some Unicode problems, but handles the connection error without crashing
It seems the domain submagic.tk is no longer valid and that may just be the cause.

0 votes
answered Oct 9 by Peter Louage

Temporary solution:
Start SubMagic - Close submagic support window, don't close the runtime error window, click any button on the command line (ex: Synchronise) sub magic will now continue working normally.

0 votes
answered Nov 2

Is the code public? Where can it be found? Anyone interested in fixing this error?
KR
Wannes

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...