First time here? Check out the FAQ!
x

Firefox 52.0.1 does not support My D-link services plugin anymore.

0 votes
asked by about mydlink services plugin
edited by

"Beginning in Firefox version 52, support for NPAPI plugins in Firefox has ended, except for Adobe Flash."

This is what I find using latest version of Firefox, meanwhile I was able to use Mydlink services plugin with previous version of Firefox. When Dlink will provide a solution or there is already one available?

Thanks and regards.

1 Answer

0 votes
answered by (309k points)

Indeed, starting with version 52, Firefox dropped support for NPAPI plugins which means that now developers have to migrate their services to newer technologies. I strongly recommend to install an older version of Firefox and disable automatic updates from the application's configuration options.

The ESR or a previous version of Firefox will still allow you to install various plugins: https://www.mozilla.org/en-US/firefox/organizations/

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...