First time here? Check out the FAQ!
x

I am asked to input the password each time I start Skype. How do I get Skype to "remember" my password?

0 votes
asked by about Skype
edited by

Although I have ticked the box to sign in automatically, I am asked to input the password each time I start Skype. Solved it once but since update I can't remember what I did. How do I get Skype to "remember" my password?

7 Answers

0 votes
answered by (100k points)
edited by

It happens when you install Skype in Windows Vista, 7 and 8 operating systems. In order to save the settings you will need to run the application as Administrator (you can do this by right clicking its icon and choose Run as Administrator) and then type your username and password. Next time when you start the application you will see that it will remember it. If you use a portable version of Skype, this could also be the problem and like in the case mentioned, you should do exactly the same thing.

commented by (100 points)
There is absolutely no reason for which Skype should require Administrator-level access to store the password for an individual user who is executing skype.exe as him or her self. Furthermore, I just launched Skype as an Administrator, logged in, exited, and tried again and indeed I am still asked for my password. At no time did a "Remember Me" checkbox appear as an option. And, ultimately, I am unwilling to accept this as a "solution" to the conspicuously absent "Remember Me" checkbox on the login screen in modern Skype versions. Microsoft needs to make this feature available and functional out-of-the-box; no completely unnecessary privilege escalations.
0 votes
answered by

But wait what if I wanted Skype to ask me for a password each time? Because my desktop auto signs me in and I want it to ask for a password.

0 votes
answered by (510 points)

Two options:
1) Run as Administrator.
2) Try some password managers, which can app autofill.
- Sticky Password (http://www.stickypassword.com/)
- Roboform (http://www.roboform.com/)

0 votes
answered by

This can happen when your Skype profile gets corrupted for whatever reason. I managed to fix it by deleting the Skype settings folder and restarting Skype. Note, however, that this will remove all the settings you have made.

Here is what you have to do:

  • Quit Skype
  • Go to C:\Users\\AppData\Roaming
  • Delete the Skype folder
  • Start Skype
  • Log in and click through the welcome wizard.
  • Make sure to change all your settings back to what they were before.
commented by (100 points)
AS of Skype 7.17.0.105, this solution does seem to work. I just tried it. Even though there is no checkbox to "Remember Me", "Remember Password", "Keep me signed-in", etc. upon logging-in, the default behavior seems to be to keep the user signed-in. Unfortunately, I tried one of the other solutions recommended here first (launching Skype as Administrator), so I'm not sure which action fixed it. I'll report back if I'm able to make a reliable determination at any point in the future. Thanks for this!
commented by (100 points)
MS removed the option at logon page, but you still able to set it once you login (Duhh), if this doesn't work because the Windows logon user isn't administrator, choose >> Run As Admin << from the SkePE icon in Programs. (it doesn't show as option when I tried from short-cut on desktop, Windows 7 Pro).
0 votes
answered by

Hey!!! Running as Administrator did it. Cool Beans.

0 votes
answered by

Deleting of AppData folder for Skype works perfectly for me, Thanks a lot for great advice.
Jan

0 votes
answered by

Hi, none of this works anymore for the windows 10 skype that autodownloads from the app store instead of skype website. The skyp "App" always asks for a account name and password. Account name is not even remembered as a drop down menu selection. any solutions?

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...