First time here? Check out the FAQ!
x

MPP File will not open

0 votes
asked by (140 points)

We have a Project 2003 file that several users are currently using. Other MPP files can be opened just fine. However this particular file will not. I have tried to restore back to a file I know was good and the restored file behaves the same exact way. This made me believe this to be a problem with Project installation, etc. I tried to remove and re-install Project 2003. Doing this fixed the ability to open the file. But alas, the very next day we come in and the file is back to having the same problem. I'm at a loss as to things to try. I've attached a screenshot of the error. Also for what its worth, I do notice that the file starts to open (about 1 second)...but then we get that error

1 Answer

0 votes
answered by (140 points)

Hello, this problem is very common.
Follow these instructions, you can restore your file.
http://www.project.repair/
1.
Be sure there are no hardware issues and that the File System is intact (run chkdsk /r and repeat until it doesn’t return errors), restore from backup is preferable if possible.
2.
Add the Exchange bin to the “path” statement
A.Start -> Right click my computer -> properties -> advanced Tab -> environment variables (scroll down if you have to)
B.In the bottom pane double click “path”
C.Go to the end of the line enter a semi-colon and enter the path to the exchange bin directory
3.
Verify that there is twice as much free space as the size of the database,
i.e if the database is 10 gb you need to have at least 20 gb free
4.
Open command prompt
5.
Change to the directory where the database is (usually C:\program files\exchsrv\mdbdata, if you cant find the database search for *.edb)
6.
Type eseutil /mh (usually priv1.edb)
Look for the shutdown state (may have to scroll up) , if its in clean shutdown then you should be able to mount the database, but chances are if your reading this its in a dirty shutdown and you need to continue on
7.
Type eseutil /k (usually priv1.edb) look for “Bad Checksums” if you have any, your repair possibility will be slim (just make a note of it)
8.
Type eseutil /ml e00 we are looking for any missing logs (if none missing go on to step 9)
if there are any we have to move all subsequent logs. and the e00 log to another location, rename the last log to e00.log
Example we have logs E00021-E00035 and E00033 is missing, remove E00, E00034 and E00035
9.
Re-name the .chk file to .oldchk
10.
Type eseutil /r E00
Wait for that to complete, if it completes successfully move on to 11 otherwise run “P”
P. eseutil /p this will force the database into a clean shutdown and will rip out any incomplete pages, this should only be done as a last resort
11.
Start information store service, verify that the store is mounted in Exchange System Manager (ESM), if its not mounted right click and mount
A.Start -> All Programs -> Microsoft Exchange -> System Manager
B.Expand Administrative Group -> Administrative group -> Servers -> {Server name} -> {Storage Group}
C.Right Click Mailbox store -> mount
12.
Dismount the store in ESM
13.
Go back to the command window
A.type isinteg –s -fix –test alltests
B.When prompted select the store that you repaired
C.If any fixes are reported re-run until none are reported (just like chkdsk)
14.
Type eseutil /d (usually priv1.edb)
15.Remount the database and should now be able to send receive mail

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...