First time here? Check out the FAQ!

I get "Error 492" whenever I try to install an application from Google Play store.

0 votes
asked by
retagged by

When I try to download something from Google Play store, it says "Error 492" and I can't download anything. My phone is a LG p990.

Thank you.

13 Answers

0 votes
answered by (100k points)
edited by

This is a frequent error among most of Android phones that were released. "Error 492" usually appears when you try to download an application from the Market, and there is an error with .android_secure directory or with the Dalvik and phone's cache. In both cases, a good approach to the problem resides in the fact that you will need to follow some steps to obtain the good functionality of the Market.

Please try these guides how to perform maintenance on your phone.

  1. SD-CARD: many users fixed their problem by formatting their card. You can do this by going into Settings > Storage > Erase SD card. A reboot is required after this operation.
  2. Phone/Dalvik cache: reboot your phone into the Recovery menu and wipe phone's cache and then dalvik cache from the advanced menu. (A ClockWorkmod recovery menu has to be installed for this kind of job).
  3. Data formatting: from the same Recovery menu, please select wipe data option and then reset your phone.

As you can see, these operations require that you go into Recovery menu. Please note that ClockWorkmod is installed with 3rd-party flashing applications and in most of the cases, performing the flash will void your warranty.

asked Mar 26, 2013
edited Mar 27, 2013 by
Error 492 in my Galaxy Nexus
0 votes
answered by

@ Andrew Constandache This just makes your phone start from scratch to face the same problem later on. It definitively doesn´t fix 492 error.

0 votes
answered by

Hi. I did this:

  1. wipe cash
  2. wipe dalvik cash
  3. with root browser I deleted .android_secure

and its working on my Wilfdfire S, CM7 :-)

0 votes
answered by

Im from colombia .. excuse my english but the thing is those were permission troubles..Someday i started to disturb my root and i get this problem ..


  1. You need to be root user and have the root explorer app on your phone.
  2. I copy two apk (For Security throw 'root explorer' in 'Mount R/W mode' otherwise your phone don't let you do that or anything at all so it is logic when you put that 'Mount mode' using the 'root explorer app').... This two apk that were responsible for downloads 'DownloadProvider & DownloadProviderUi' were uninstall by me because of stupid thoughts.
  3. i get this error from google market 'n i realize that maybe i shouldN'T have uninstalled those apks for testing.
  4. i tried to reinstall this two but the thing is ... WHEN YOU DO SOMETHING .. DO IT BUT ON THE RIGHT WAY.


  1. You have to put this two app OR ANOTHER APP DISTURBED THAT YOU MIGHT THINK ITS THE PROBLEM in the carpet '->system->app ' of course using 'root explorer app' in 'Mount_R/W mode'.. just a little nice copy again with permissions and a little click and install.
  2. Maybe you have already installed the app with the problem on your system folder .. the thing is .. one actualization could make wrong things to your apps but don't worry now you know how to solve this sort of problems.
  3. The next step its the only one and it is hold your finger (On the disturbed app) 'till you get a little bunch of options .. get into permission option (My spanish phone says 'Permisos') .. You check every box on read-permissions .. You check only the owner box in write-permissions .. finally you check NO box on (i guess 'ejecucion') execution-permissions. And thats all.
  4. I just make a knot in my head for a half hour but finally i found this solution and actually the checks for permissions that i described on the three step was from one of the predetermined apps on my phone that actually all this predetermined apps have the same permissions config.


  1. You just need put your f** disturbed app in the system app folder (Optional .. maybe those apps are already there).
  2. Put right check config of permissions ...(actually you could take a look to other apps predetermined just like an example so you can know how you have to do this config).
  3. After you put this permissions then you have a 'system app' manually config (like another "system stuff" in every machine on the planet surface .. One special place to install .. One special permission config for them).
  4. to solve some doubts the 'Mount R/W mode' is a upper button that says 'Mount R/W' on the 'root explorer app'.. you click on it and get the R/W mode .. then your button turns into 'Mount R/O' label, that means you put the R/O mode with another click but this its not what we want.. we want the R/W mode .. Just feel free to click this button and get into folders no problem just don't eliminate what you don't know.
  5. Those *** errors (i guess) its the same **** .. some system app that you lose or not even get the right permissions .. yet. ;)
0 votes
answered by

I get this error sometimes here and there. Alot of times if I wait several hours I can download the app I was wanting to again. Google won't admit it, but I think it means that Google's servers are overloaded.

0 votes
answered by

I got this error when I queued several apps for download. I waited about 10 minutes and could download all the apps separately without any trouble. I think it's got to do with Google's servers as well.

0 votes
answered by

*I had this error but after a while I could download the app I was unable to earlier,so my conclusion is that its an internal program problem within Google play itself!! *

0 votes
answered by

Just clear the cache of google play app frpm application manager and it's done.

commented by (100 points)
tried this on my son's android phone and it absolutely worked! thanks much...God bless!
0 votes
answered by

follow steps: "settings"
2. application manager
3. click "all"
4. google play store
5. force stop
6. clear data
7. back to setting
8. accounts
9. google
10. click the acount
11. remove account
12. restart
13. play store and sign in
14. uncheck communication

and there you go,,

0 votes
answered by

I just fixed this problem by going into Settings->Storage->Erase SD card
It really worked for me and I tried lots of other stuff that didn t help me at all but this will most probably help you

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register