First time here? Check out the FAQ!
x

Compatibility of Pamm with Windows 8.1.

0 votes
asked by
edited by

I want to know if Pamm software Of NSDL is compatible with Windows 8.1 or not?

1 Answer

0 votes
answered by (236k points)
edited by

The PAMM software is a part of the trading tools available, however, you need to create an account on the NSDL website to download the client. You can download the client after you have created an account. Since this is not available for public, you might need to contact the support technicians before downloading. And yes, you can install PAMM in Windows 8.1 since it's using MetaTrader client which is also compatible with Windows 8.1.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...