First time here? Check out the FAQ!
x

Caere Omnipage v10.0

0 votes
asked by
edited by

I have Windows XP with service pack 3 using USB connection. Is it compatible with Caere Omnipage v10.0?

1 Answer

0 votes
answered by (9.6k points)

The official system requirements state that it is compatible with Windows 95, 98, 2000 or NT 4.0, but it should work on Windows XP as well.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...