First time here? Check out the FAQ!
x

AVG 2013 compatibility issues.

0 votes
asked by
edited by

I have the latest version of Windows on my PC and I can't load Internet Security 2013. It says there are compatibility issues. When I run troubleshooter I get the same error. I am trying to load to an earlier version of Windows, but it still says it has compatibility issues and can't find any solutions.

1 Answer

0 votes
answered by (236k points)
edited by

Internet Security 2013 is not available anymore from the official website. The product is now called Internet Security 2014. You need to download this version if you want to make it work in your computer. The software is compatible with all modern versions of Windows (Xp, Vista, 7, and 8), both 32 and 64bit. Visit the official website to obtain a download for this product.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...