First time here? Check out the FAQ!

Geocaches doesn't recognize the Garmin Communicator Plugin.

0 votes
asked by about Garmin Communicator Plugin
edited by

I've downloaded the Garmin Communicator Plugin and I received the confirmation message that it's downloaded. When I'm trying to download Geocaches from, it says that I don't have the plugin. I reinstalled the plugin without success. Can you help?

1 Answer

0 votes
answered by (132k points)

In order to fix the issue, you will need to enable the plugin from your browser's settings. If you're using Mozilla Firefox, press the icon and click the Add-ons option. Open the Plugins tab and select Always Activate from the drop-down list next to Garmin Communicator Plugin.

If you're using Google Chrome, type chrome://plugins/ in the address bar and press Enter. After that, press the Enable button below Garmin Communicator Plugin:

enter image description here

In Opera, you need to type opera:config#Extensions|Plugins in the address bar and to press the Enable option next to the plugin.

If you're using Internet Explorer, launch the browser, press the Alt key and select Manage add-ons from the Tools menu. After that, click the Toolbars and Extensions option, select the Garmin Communicator Plugin and press the Enable button.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register