First time here? Check out the FAQ!
x

Using Cubase 6 on a new computer.

0 votes
asked by
edited by

Which is the latest OS version that can combine Cubase 6 with? Can I install Cubase 6 on Mac OS 10.9?

1 Answer

0 votes
answered by (194k points)

Cubase 6 does not support Mac OS X 10.9. The latest version supported is Mac OS X version 10.4. To be able to install it in 10.9, version 7.5 needs to be used. You can acquire it from the official website. On the linked page, you also have the system requirements for this application to run properly.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...