First time here? Check out the FAQ!
x

I can't connect to my PC from my Android mobile.

0 votes
asked by
edited by

I used to login from my Sony Xperia U to my PC but after the update (I don't know if it's just coincidence or not), when I try to login to my PC from my Android Sony Xperia U, I see the screen turns to deep blue to my PC. My Android device shows connected and after one second or less, shows that the session successfully ended. I uninstalled, I reboot my mobile and re-installed Teamviewer on my Android device. On the other hand, I have used both version 8 and 9 (full and quick support) to my PC but this problem keeps on existing. I also tested another application that connects mobile with PC and it's working fine (Splashtop). I'm really wondering what is wrong because it's not that I can't login, but the session ends automatically after one second. Is it the firewall? I have disabled the firewall and it keeps on doing that. If the problem is the settings of my firewall, why was it working fine few months ago?

P.S: Just in case, the resolution of my Android phone (Sony Xperia U) is 854 x 480 and my PC's resolution is 1680X1050 (Windows 7 Ultimate and I use Comodo firewall)

1 Answer

0 votes
answered by (329k points)
edited by

The first thing to do is to re-install everything, from the application on your mobile to the application on your computer. For the time being, you should use Splashtop as an alternate way until the problem is fixed. Download and install the latest version of Teamviewer on both phone and PC, then make sure to disable any options related to unattended access. The firewall has nothing to do because Teamviewer overcomes its restrictions. To successfully connect to PC, make sure to also install the Samsung add-on for Teamviewer on mobile. It will enable remote support.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...