First time here? Check out the FAQ!
x

My Tango application won't update.

0 votes
asked by
edited by

Upon updating Tango, I get this message that states: "Your device is not compatible". What can I do to fix this?

1 Answer

0 votes
answered by (80k points)
edited by

It seems that this is an internal error of the Google Play store. Unfortunately, there isn't a known solution until this point. However, you can try several things that might help. On your device, go to Menu > Settings > Applications > All tab > tap on the Google Play application > Clear Data > Clear Cache. After you did this, try again to update the application.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...