First time here? Check out the FAQ!
x

Bluestacks is not working properly

0 votes
asked by
edited by

I've tried installing The HD setup thing; once done, I quitted it and tried to install using thinstaller, but it said a version of bluestacks had been already installed. Can you help me?

related to an answer for: Bluestacks doesn't start

1 Answer

0 votes
answered by (236k points)
edited by

I would like to recommend cleaning the computer and the registry items. You can use CCleaner to uninstall the application, then click on the Registry to clean the obsolete registry files. After this procedure, restart the computer. Download the Bluestacks installer again, right click it, and select Run as Administrator. Follow the instructions and the application will be installed normally.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...