First time here? Check out the FAQ!
x

Download availability of a newer version.

0 votes
asked by (120 points) about BusinessPhone Management Suite
edited by

I'm trying to access my PABX using BMS version 3.3, but unfortunately I cannot access it because it's telling me that I need a newer version of BMS with R17. My current version has only R16. What should I do in this matter?

1 Answer

0 votes
answered by (77.9k points)
edited by

In this matter, the only thing that you can do is to download a newer version of BusinessPhone Management Suite. However, on the official website of the developer, there is nothing mentioned about the availability of the product. This might be discontinued. To fix your problem, use the site mentioned to contact the developer for additional information.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...