First time here? Check out the FAQ!
x

Is version 3.0 better than version 1.0?

0 votes
asked by about Canon MP Navigator
edited by

Currently, I'm using Canon MP Navigator 1.0 with my LIDE 90 printer. Will version 3.0 give me a better service?

1 Answer

0 votes
answered by (132k points)

The answer is no. At this time the latest version of the application compatible with your printer model is Canon MP Navigator 1.07. From what it seems the version 3.0 is not developed to run with your Canon LIDE 90. You can download and install the latest version of the application from the official web page. Click Drivers & Software tab, select your operating system if it is not automatically detected, expand the Software list and download the file.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...