First time here? Check out the FAQ!
x

My Canon Printer is not compatible with Internet Explorer 9. Is there a later version that is compatible?

0 votes
asked by
edited by

My Canon Printer is not compatible with Internet Explorer 9. Is there a later version that is compatible & if so how do I get it ? My Computer is Vista Home.

1 Answer

0 votes
answered by (15.7k points)

This error can be fixed by installing 3 update patches on your computer. First, go to this link http://support.microsoft.com/kb/971512 and install the first update. Second, install this one http://support.microsoft.com/kb/2117917 If you are using a x64-based version of Windows Vista, download and install this package http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=23389 while for the x86-based version of Windows Vista, you will have to go use the application from this address http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=22050 After completing these simple steps, you should be able to use your printer without any trouble.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...