First time here? Check out the FAQ!
x

If I downloaded and installed version 15.2.48.2 do I still need to install version 15.1.37.2 as well because it still shown in Software Informer as a new version despite "refreshing" after installing 15.2.48.2 ?

0 votes
asked by (120 points) about TurboCAD Deluxe

If I downloaded and installed version 15.2.48.2 do I still need to install version 15.1.37.2 as well because it still shown in Software Informer as a new version despite "refreshing" after installing 15.2.48.2 ?

1 Answer

0 votes
answered by (4.9k points)

No, you do not need to do it. Where exactly do you see that the new version is 15.1.37.2?

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...