First time here? Check out the FAQ!
x

Information about Safari.

–1 vote
asked by (140 points) about Safari
edited by

Which version of Safari do I need to run on OS X 10?

2 Answers

+1 vote
answered by
 
Best answer

see copatability in home page of safari website before download..

0 votes
answered by (132k points)

It depends on what version of Mac OS X you're using. Safari 1.0 works with OS X v10.2 and OS X v10.3. Safari 2.0 has been developed to run on Mac OS X v10.4, Safari 3.0 can be used with Mac OS X v10.5, Safari 4.0 is compatible with Mac OS X v10.6, Safari 5.0 has been developed to run with OS X v10.7, Safari 6.0 can be used on OS X Mountain Lion, Safari 7.0 has been released for OS X Mavericks, and Safari 8.0 is developed to run on OS X Yosemite. For further information, I recommend you contact Apple support team.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...