First time here? Check out the FAQ!

BlueStacks is stuck on the "Loading..." screen.

0 votes
asked Jul 25, 2013 about BlueStacks
edited Aug 5, 2013 by Danford Blitz

Maybe about 6 days ago my BlueStacks crashed while I was on Instagram. It was frozen for a long time & I finally clicked the "X" button, then tried to restart it again and it has been saying just "Loading.." ever since. I have un-installed it using Control Panel and re-downloaded an older version with the blue screen, then a newer version with the black screen & rebooted my computer several times. But nothing is working, it still says "Loading.." I tried leaving it up loading over night, but it usually restarts the whole computer. I've been searching for ways to fix it but it all says: "Download the new version", but I did that already. So does anyone know how to get it to load correctly? Maybe, install or uninstall something?

10 Answers

0 votes
answered Jul 26, 2013 by Pete Clapp (193,030 points)
edited Aug 5, 2013 by Danford Blitz

You will need to completely uninstall the application and the remaining registry keys, folders and files. Proceed to uninstall BlueStacks in the old fashion way, then use CCLeaner or any other cleaner to remove the remaining registry files. You will need to delete BlueStacks folder from C:\ProgramData\BluestacksSetup and download a fresh copy of the software. I can assure you it will work. If the uninstallation procedure will ask you about saving the data, choose NO and proceed.

0 votes
answered Nov 6, 2013

PETE, I followed your instructions and I can safely say that bluestacks still does not work. Do not assure anyone in the future please!

0 votes
answered Nov 8, 2013

I have solved without uninstal...
1. In task manager Stop the process that starts like 'HD-**'
2. Go to services and stop the services starts like 'BlueStack'
3. In task manager, Click show process from all user and stop the process starts like 'HD-
4. Start the bluestack

commented May 24, 2014 by mAx 15 (100 points)
worked!!, thanks man :)
commented May 19, 2015 by Preyan.J (100 points)
Thanks a lot,it's working now
0 votes
answered Nov 9, 2013

my one is same problen did you tried version 0.8 my one is working after updating

0 votes
answered Nov 26, 2013

maybe try running it as administrator. i think it will work... I just searched it... maybe because it is beta only, so it has bugs and issues

commented Dec 10, 2014 by Guest_104208285 (510 points)
Running as Administrator does not help.
0 votes
answered Dec 11, 2013

same problem. The re-instal process and clean clean ang clean. but still didn't work.

0 votes
answered Jan 11, 2014

Windows Registry Editor Version 5.00


commented Dec 10, 2014 by Guest_104208285 (510 points)
I added this key into Windows 7 and 8.1 Pro but no joy.  BlueStacks goes to black screen about 30 seconds after initialization.
0 votes
answered May 27, 2014

Thanks man... its worked for me!! Just stop the process starts from "HD-" and then go to Services tab stop the services starts with "Bluestack" (see the service description)

0 votes
answered May 27, 2014

it is worthless. i have gone to process and stop starting with hd and whatever you said.but no change it is coming black screen only.
give me another idea

0 votes
answered May 24, 2015 by Goggles Pisano

Worked for me! Awesome! Thank you. Stopped all the Bluestacks services and when I retried Bluestacks, it came up with no hiccups. Now all we need to do is inform Bluestacks of this cure and maybe they can do something about fixing this malfunction.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register