First time here? Check out the FAQ!
x

HP Deskjet 3070A e-All-in-One Printer problem

0 votes
asked by
retagged by

Trying to install HP Deskjet 3070A e-All-in-One with the CD provided but the answer is that it requires Mac OS X version 10.6 or earlier and my OS version is 10.7.5.

Can you help please?

1 Answer

0 votes
answered by (100k points)
edited by

The Support CD was shipped when there was no update available for the Mac OS (1.6 and prior) but as time passed there were released newer versions of the OS and so you will need to download a new version of the driver compatible with updated versions of the OSX system.

Kindly, visit the following Support link and download the appropriate driver and software because I have checked them and they work for 10.8 version and prior.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...