First time here? Check out the FAQ!
x

Is this compatible with a Galaxy Note 3?

0 votes
asked by about Samsung SideSync
edited by

Is this compatible with a Galaxy Note 3? I have Android version 5.0. Or should I download the 4.0?

1 Answer

0 votes
answered by (329k points)

Version 4.0 of the SideSync application is compatible with the following devices:

All Samsung Android phones Galaxy S III and later running Android KitKat 4.4 and above.
All Samsung Android tablets running Android Lollipop 5.0 and above.

Your phone needs to have Android 4.4 or later and it should work properly.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...