First time here? Check out the FAQ!
x

JCY-1800 VDR Mac compatibility.

0 votes
asked by about JCY-1800 VDR Playback
edited by

Is JCY 1800 compatible with Mac OSX version 10.11.5?

1 Answer

0 votes
answered by (329k points)

I don't think it has support for Mac OSX version 10.11.5 because the product is discontinued, therefore support has been stopped regarding firmware or any other programs that were previously still available.

I've also searched for replacement or something to use as an alternative, but there is nothing available.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...