First time here? Check out the FAQ!
x

Question about "Magicard ID" V3.05.

0 votes
asked by about Magicard-ID
edited by

I have V3.05 and I am getting a message about upgrading, but the link goes to invalid site. What can I do? Should I upgrade to Trust ID Pro, but will I lose my card designs and settings?

1 Answer

0 votes
answered by (309k points)

The Magicard-ID application doesn't appear to be supported on the official website. I've checked their support section and all the available information on the product pages and still I didn't find anything about it. However, you should export the content from Magicard-ID or install Trust ID PRO to see if it supports the old format and then make the switch.

Access the following page and then scroll down to the bottom of the page. Use the contact info that corresponds to your country/continent: https://support.ultraid.com/

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...