First time here? Check out the FAQ!
x

Looking for Elite compatible with Mac Pro 10.5.8.

0 votes
asked by about Transcend Elite
edited by

I have Transcend StoreJet 2TB and I am looking for Elite compatible with Mac Pro 10.5.8.

1 Answer

0 votes
answered by (264k points)

According to the data on the official website, the Transcend Elite works with the following operating systems:

  • Microsoft Windows XP
  • Microsoft Windows Vista
  • Microsoft Windows 7
  • Microsoft Windows 8
  • Microsoft Windows 8.1
  • Microsoft Windows 10
  • MAC OS 10.7 or later

As you can see there is no version for 10.5.8. Most likely the lack for 10.5.8 exists because that version doesn't meet the requirements for all the features offered through application.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...