First time here? Check out the FAQ!
x

How to upgrade Rail Maze 2 from 1.2.4?

0 votes
asked by

About half the levels I get recently on Rail Maze 2 V 1.2.4 running under OS X 10.9.6 say that I must update my game to run those levels.

I can't find an update from V1.2.4 for OS X. How do I run those levels?

1 Answer

0 votes
answered by (264k points)
edited by

I have checked the Mac App Store, and the latest version is 1.2.4. There is no newer version. I have tried to update it after it was installed, but without luck. If you believe this is an error, contact the developers using the following website: http://www.spookyhousestudios.com/railmaze2.html

The contact options are are located on the bottom of the page.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...