First time here? Check out the FAQ!
x

Super GeoGPS full for Android.

0 votes
asked by
edited by

Google Play says "My device is not compatible". My question is: what device is this designed for?

1 Answer

0 votes
answered by (236k points)

This application requires a device with Android 2.2 and up. However, in some cases, your device might not be compatible because of various reasons like performance, lack of support, lack of testing etc.

The best way is to send an email to the developer and inform him about this issue. Use the following email to contact him: xmeasure.vn@gmail.com

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...