First time here? Check out the FAQ!
x

Skype for Mac Os X 10.7.5

0 votes
asked by
edited by

What version of Skype do I use for Mac 10.7.5? And where do I get it?

1 Answer

0 votes
answered by (264k points)

You need Skype 6.15 to be able to install it on Mac OS X 10.7.5. Luckily, the developers provided a page with information and the downloads necessary for that version of OS X.

You can use the direct download URL: http://download.skype.com/macosx/Skype_6.15.0.335.dmg

Browse the page with the information: https://support.skype.com/en/faq/FA34498/which-version-of-skype-for-mac-os-x-do-i-need

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...