First time here? Check out the FAQ!

ASUS WebStorage Remote Drive unavaiable on X205TA.

0 votes
asked by about ASUS WebStorage Remote Drive
edited by

I installed ASUS WebStorage Remote Drive on X205TA and the mount was successful (drive X: appears in system), but is not accessible.

1 Answer

0 votes
answered by (236k points)

You need to check the firewall installed on your computer. Go to Control Panel > System and Security > Windows Firewall. You can either add the software to Exclusion list or simply turn it off then try accessing the drive again. I have encountered the same error with other cloud storage solutions as well and this fixed it. Additionally, check the login details in the Asus WebStorage.

If you still encounter issues, contact the Customer Care that's always available for users who access the service:

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register