First time here? Check out the FAQ!
x

I have a Canon MG5220 printer/scanner and Windows Vista. What version of MP Navigator do I need?

0 votes
asked by
edited by

I have a Canon MG5220 printer/scanner and Windows Vista. What version of MP Navigator do I need? I downloaded v3.1 and it doesn't work.

1 Answer

0 votes
answered by (100k points)

The version of your MP Navigator is outdated and on the support website for your printer there is a new version which works with latest operating systems. The file is available here and it's provided free of charge. Before using the application for your own purposes, the driver has to be installed on the operating system so MP Navigator recognizes the device. The driver package is available from the same place where you get MP Navigator.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...