First time here? Check out the FAQ!
x
 Windows  Mac  Android  Answers  Forum

Asherons Call Throne of DestinyAsherons Call Throne of Destiny ›  Why can't I run Asheron's Call in my app permission dictionary?

0 votes

I want to run Asherons Call on my Windows 8 laptop. I've downloaded it, but it does not let me play it.

asked Feb 5, 2016 by Guest #41006286 (120 points)
edited Feb 29, 2016 by Daisy Guaty 1

1 Answer

0 votes

I have downloaded the game and installed it without errors. On Windows 8, the only requirement is that you need to be logged in with an Administrator user. Once you have the installation package, right click it and choose Run as Administrator, then if it's possible, choose another partition to install the game.

To obtain the latest installer, visit the following URL: https://www.asheronscall.com/en/content/downloads

Note: I have used Windows 10 x64 and it worked normally.

answered Feb 11, 2016 by Alex Urbach (291,140 points)
edited Feb 29, 2016 by Daisy Guaty 1

Your answer

Your name to display (optional):
Email me at this address if my answer is selected or commented on:
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...