First time here? Check out the FAQ!
x

Issue with password less sftp2 using F-secure SSH Client.

0 votes
asked by about F-Secure SSH Client
edited by

I am facing problems while trying to do a password less SSH to Unix box from Windows. Public key was generated using F-secure. When the F-secure client attempts, it connects without password but when I try to use sftp2 in command line it prompts for password.
I have tried several options and failed. Not much help in Google too.

Any response to possibilities will be much appreciated.

Below is the sftp2 -v output:

C:\Documents and Settings\hp-\Desktop>sftp2 -v mha@10.205.50.190
SshFileCopy: Making local connection.
SshFileXferClient: extname newline@vandyke.com', data: 00000000: 0d0a .. SshFileXferClient: Negotiated version: 3 (own version: 3, remote version: 3). SshFileCopy: Connection to local, ready to serve requests. Sftp2: Connection ready. SshReadLine: Initializing ReadLine... SshFileCopy: Connecting to remote host. (host = mha@10.205.50.190, user = NULL, port = NULL) Sftp2: Couldn't find ssh2 on path specified (ssh2.exe). Trying default PATH... SshConfig: Unable to open C:/Documents and Settings/hp-/Application Dat a/F-Secure SSH/ssh2_config SshReadLine: Initializing ReadLine... client supports 3 auth methods: 'keyboard-interactive,publickey,password' Ssh2Common: local ip = 10.10.49.141, local port = 2190 Ssh2Common: remote ip = 10.205.50.190, remote port = 22 SshConnection: Wrapping... Remote version: SSH-2.0-ReflectionForSecureIT_7.2.0.115 Ssh2Transport: My version: SSH-1.99-3.2.3 F-Secure SSH Windows Client Ssh2Transport: lang s to c:', lang c to s: `'
Ssh2Transport: c
tos: cipher 3des-cbc, mac hmac-sha1, compression none
Ssh2Transport: s
toc: cipher 3des-cbc, mac hmac-sha1, compression none
Remote host key found from database.
Ssh2Common: Received SSH
CROSSSTARTUP packet from connection protocol.
Ssh2Common: Received SSH
CROSS_ALGORITHMS packet from connection protocol.
server offers auth methods 'publickey,keyboard-interactive,password'.
Ssh2AuthKbdInteractiveClient: Starting kbd-int auth...
Keyboard-interactive:
Password:

1 Answer

0 votes
answered by (236k points)
edited by

It seems that you are lacking SSH installation in Windows. Try to install OpenSSH for Windows first. Additionally, I believe that you will not be able to create a connection without a password because the password is actually the key to establish a successful connection even if you have a PGP key. Assign passwords then you will be able to connect.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...