First time here? Check out the FAQ!
x

I can't use iBall 3.5G Connect with Windows 8.1. Can you help?

0 votes
asked by about Windows Driver Package - iBall Connect Modem
edited by

I can't use iBall 3.5G Connect with Windows 8.1. Can you help?

1 Answer

0 votes
answered by (193k points)

Unfortunatly, as you can see on the official web page, the utility is compatibile only with Windows 2000, Windows XP, Windows Vista, Windows 7, Windows 8 and MAC OS 10.8.2 platforms. It is not developed to run on Windows 8.1 systems. However, you can try to install the driver from the Downloads section in Compatibility Mode.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...