First time here? Check out the FAQ!
x

CutMate supplied with Redmate

0 votes
asked by about CutMate
edited by

I am opening a small market sign shop in Sheet Harbour NS. I have just purchased a RS720C printer from UNI-CUT in Markham ON. I have a little trouble understanding my contact at UNI-CUT so I'm asking you.

What versions of Corel Draw Suite are compatible with CUT-MATE and my cutter?

1 Answer

0 votes
answered by (194k points)

According to the information found in the user manual, the CutMate application requires Corel Draw 11, 12, X3 or X5. If you have another version except the ones from the mentioned list, then CutMate won't display the dialog to import it into Corel Draw. The latest version of Corel Draw is not compatible with CutMate, but you can use Amazon to buy it.

The latest version of CutMate is 2.3.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...