First time here? Check out the FAQ!
x

KMPlayer side screen webpage.

0 votes
asked Sep 17, 2013 about The KMPlayer
edited Sep 18, 2013 by Stephen Prastman

In the latest KMPlayer version, every time I start playing a file the screen launches a window to the right side, showing an unreachable webpage.

I want to stop that from happening. Can you tell me how?

20 Answers

+1 vote
answered Sep 19, 2013

just edit you hosts file, located in
c:/windows/system32/drivers/etc/host
and add
127.0.0.1 player.kmpmedia.net
this will prevent the kmplayer to connect to the internet and no sidebar will appear!

commented Sep 20, 2013 by Adam 14 (100 points)
thank you for all your INFORMED answers.

i had to get an account to say that! :D
commented Sep 25, 2013 by Thibaut Chevallier (100 points)
this tip worked, too bad this can't be disabled with a single option in the software :(
Does modifying host make other changes in windows or softwares ?
commented Oct 26, 2013 by panserfaust (100 points)
sir, does this also prevent the player from checking itself for updates?
+1 vote
answered Sep 25, 2013
reshown Sep 30, 2013 by Adam Black

Or you can just add KMPlayer to your firewall settings, so this app is not allowed to connect to the internet.

+1 vote
answered Oct 1, 2013

Just add player.kmpmedia.net to the site blocking tab of any internet security

+1 vote
answered Jan 12, 2014

You'll have to edit the hosts file located in
c:/windows/system32/drivers/etc/host

I've had a look at the installer and tracked the internet access with Wireshark. I added the following lines to my hosts file:

0.0.0.0 player.kmpmedia.net
0.0.0.0 cdn.pandora.tv     # CSS for kmpmedia.net, Ads and Installer-Query
0.0.0.0 cdn_dot_pandora.tv
0.0.0.0 update.kmpmedia.net
0.0.0.0 cdn.pandora.tv.edgesuite.net
0.0.0.0 a1414.g.akamai.net    # Akamai Network, for additional files
0.0.0.0 ads.pandora.tv
0.0.0.0 anx.apnanalytics.com
0.0.0.0 cdn.ptvcdn.net
0.0.0.0 klvi.com
0.0.0.0 pipoffers.apnpartners.com
0.0.0.0 ak.pipoffers.apnpartners.com
0.0.0.0 apnmedia.ask.com
0.0.0.0 apnstatic.ask.com
0.0.0.0 about.ask.com
0.0.0.0 apnpip.ask.com
0.0.0.0 www.163.com
0.0.0.0 g.163.com

If you access the Website of KMPlayer you'll have to comment out "cdn.pandora.tv". Chinese people may want to comment out "*.163.com".

You should also disable the KMP+ Skin and switch to the defaut one: Right Click ->Skin ->Logo-> .

0 votes
answered Oct 18, 2013

add an Empty file called index.htm to the LOGO subfolder and the sidebar is disabled

commented Nov 19, 2013 by Zaky Mfa (100 points)
thanx bud.it means alot to me
commented Dec 29, 2013 by Isuru Jayasinghe (100 points)
worked !! thanks!
commented Feb 21, 2014 by peter 27 (100 points)
Thank u very much...!! GREAT!!!
commented Mar 24, 2014 by miladrzn (100 points)
nice trick thanks alot :D
commented Jun 5, 2014 by aa.itisme90 (100 points)
very nice, thanks so much
0 votes
answered Oct 18, 2013

First solution for this is : Stick to the older version witch is ads free KMPlayer_3.6.0.87.exe (Google around to find this file on the web)

0 votes
answered Oct 23, 2013

Go to Control Panel>Network and Internet>Internet Options>Security>Restricted Sites>Sites. Add player.kmpmedia.net and restart the player

commented Feb 4, 2014 by ajjoshi129 (100 points)
this absolutely works..... thnx
commented Apr 23, 2014 by ryadan75 (100 points)
Absolutely perfect !!! It works for me and thanks to you I'm done with these boring pubs. Thanks a million times bro (or sista !!!)
0 votes
answered Nov 6, 2013 by jkiller (220 points)

If you are a KMPlayer user you may have encounter annoying pop ups of different media ads and other useless stuffs like this:

This can be very annoying if you don’t want any suggestions or advertising made on your media player. More of all the KMP users are using it for the simplicity of it, so making it complex would defy its purpose it had been serving. But luckily you can remove all these annoying ads in KMplayer using this simple trick. I am going to recommend you the hosts file editing approach. Add this following line to your hosts file:

127.0.0.1 player.kmpmedia.net

You can find host file under C:/windows/system32/drivers/etc/hosts

Right click on it go properties>security>edit>users> check all the boxes to allow.

Now open with the host file with notepad, now you can edit it. Paste the line and save. You are done! Now no pop ups will appear on kmp and you can enjoy your preferable media without any disturbance :)

Source: http://betdownload.com/kmplayer-12-download

0 votes
answered Nov 8, 2013

Thanks,

Go to Control Panel>Network and Internet>Internet Options>Security>Restricted Sites>Sites. Add player.kmpmedia.net and restart the player

Works Well.

commented Jun 17, 2014 by Peppo Yonchev (100 points)
This method works great! Thank you
0 votes
answered Jan 1, 2014

You can disable it by navigating to: 'Right-click menu > Skins > Logo' & Selecting ''. Sidebar can be disabled by creating an empty index.htm file inside the Logo subfolder of KMPs instalation directory.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...