First time here? Check out the FAQ!
x

Can I usu DDDL 6.3 software to diagnose ddec IV?

0 votes
asked by about Detroit Diesel Diagnostic Link
edited by

Can I usu DDDL 6.3 software to diagnose ddec IV?

1 Answer

0 votes
answered by (194k points)

Yes, the DDDL 6.3 version can be used for the following DDEC versions: DDEC II, III / IV / V, all software versions of the MBE 900 and 4000 On Highway engines and DDEC Reports. It is said that the DDDL 7.0 needs to be installed as well for maximum compatibility. The seller states that both applications can be installed in case you need one of them.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...