First time here? Check out the FAQ!
x

Will this work on a Mac with macOS High Sierra version 10.13.1?

0 votes
asked by about Canon Print Studio Pro
edited by

Will this work on a Mac with macOS High Sierra version 10.13.1?

1 Answer

0 votes
answered by (329k points)

The version 2.2.0 of Canon Print Studio Pro is listed with the following system requirements:

macOS 10.13
macOS v10.12
OS X v10.11
OS X v10.10
OS X v10.9
Mac OS X v10.8
Mac OS X v10.7

As you can see, version 10.13 is supported. You can follow this link to reach the official page with the latest update that's compatible with OSX 10.13.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...