First time here? Check out the FAQ!
x

Is this compatible with the Sabine NAV 3600?

0 votes
asked by about Sabine Navigator
edited by

Is this compatible with the Sabine NAV 3600?

1 Answer

0 votes
answered by (329k points)

Typically, this application is compatible with the Sabine navigators, but to be sure, locate the CD of the device where you will find all the necessary applications that allow you to configure and control the Sabine NAV 3600.

There is also a PDF guide that you can use to see how to configure the application. I recommend downloading it using the following link.

Note: Make sure that you have a working PDF reader installed in your PC.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...