First time here? Check out the FAQ!
x

Mac OS X 10.6.8 compatibility for FortiClient

0 votes
asked by (120 points) about FortiClient
edited by

Hello. What's the last FortiClient version compatible with Mac OS X 10.6.8 and where to download it from? Thank you by advance.

1 Answer

0 votes
answered by (264k points)

According to the Data Sheet found on the application's official web page, the latest version of FortiClient is compatible with:

  • OS X 10.8 Mountain Lion
  • OS X 10.9 Mavericks
  • OS X 10.10 Yosemite
  • OS X 10.11 El Capitan

You can get the file from the previously mentioned website, but the older versions of the application are no longer available for download.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...