First time here? Check out the FAQ!
x

Version 1.0 needed.

0 votes
asked by about CutStudio
edited by

I need version 1.0 to install my version of Cut Studio. Can someone send it to me?

1 Answer

0 votes
answered by (309k points)

You can still obtain the application, but only after you've logged on the Rolanddga website where the software is hosted. If you don't have an account, you can create one following the link on the same page.

The software will be available after you log in with your username and password.

Use the following link to fill the form to request an account: https://myroland.rolanddg.eu/request.html?type=product_owner

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...