First time here? Check out the FAQ!
x

Will Painter Essentials 4 work on Mac OS 10.12.

0 votes
asked by about Corel Painter Essentials
edited by

Will this work on Mac OS 10.12?

1 Answer

0 votes
answered by (309k points)

The version 4 of Corel Painter Essentials is compatible with the following versions of Mac:

Mac OS® version:
• Mac OS® X (10.4 or 10.5 with latest updates) • Power Mac® G4, 700 MHz or greater • 256 MB of RAM • Mouse or tablet • 24-bit color display • 1024 × 768 screen resolution • CD drive

As you can see, there is no support for Mac OS 10.12 (Sierra). However, version 5 of Painter Essentials is compatible with OSX Sierra as you can see in the image below:

System Requirements for Essentials 5

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...