First time here? Check out the FAQ!
x

Hub Manager for Windows 10.

0 votes
asked by
edited by

Installed Windows 10. Hub Manager v8.1.3.30 does not work now. Do you have a newer version that will work?

1 Answer

0 votes
answered by (236k points)

Based on the data found on the official website, Hub Manager's latest version is compatible with Windows 8.1. There is nothing related to Windows 10. This is also the cause to the errors you have.

You can check for additional details on the following website: http://www.nortekcontrol.com/product_detail.php?productId=1293

You can download the updates from the following website: http://www.nortekcontrol.com/downloads.php#ieiaccess

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...