First time here? Check out the FAQ!
x

Java Error - TCX Convertor update required.

0 votes
asked by about TCX Converter
edited by

I'm running El Capitan on latest Apple OSX and when I try to generate a FIT file from a GPX I get an error message saying I need to install a JDK. I understand from a Google search that it's because of later Java updates making the TCX Convertor buggy. Please advise about workarounds or when a patch or update will be released.

Great program otherwise and if it worked for me in this respect, worth a donation.

1 Answer

0 votes
answered by (329k points)

When you encounter these situations, it's best to stick with official ways, meaning that you should have JDK installed. JDK is available for Mac OSX. I recommend you visit the Apple page linked below to see a solution for this issue. It has been confirmed that even after you have Java installed, El Capitan still gives you errors about it.

Apple page: https://support.apple.com/kb/DL1572?locale=en_US

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...